User Tools

Site Tools


howto:openfoam

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
howto:openfoam [2019/07/09 13:41]
ccrosby [Running OpenFOAM]
howto:openfoam [2019/07/15 12:00] (current)
agill
Line 9: Line 9:
 ===== Running OpenFOAM ===== ===== Running OpenFOAM =====
  
-This section describes how to run OpenFOAM on the clusters at CHPC. Versions 2.2.2, 2.3.0, 2.4.0, 3.0.1, 4.0, 5.0, 6.0, v1606+, v1612+, v1706, v1712, v1806, v1812, v1906 and foam-extend-3.1 are installed in ''/​apps/​chpc/​compmech/​CFD/​OpenFOAM''​. ​ Source the required environment from one of the files OF222, OF240, OF301, OF40, OF50, OF60, OF1606+, OF1612+, OF1706, OF1712, OF1806 or OF1906 respectively,​ as illustrated in the example job scripts below. ​ Please be aware that v1812 and v1906 use MPICH rather than OpenMPI, and the mpirun command ** has to ** select the use of the Infiniband network interface. ​ Also, you may need to source the file from your .bashrc file, to ensure that the compute nodes have the right environment. ​ This ** should ** not be necessary, but it is sometimes a useful workaround if you experience MPI troubles. ​ It is assumed that you are familiar with running OpenFOAM solvers in parallel, and have already set up the case directory. The Gmsh and cfMesh meshing utilities are also installed and are added to the executable path when any of the OFxxx files are sourced. OpenFOAM-extend-3.1 has been installed on an experimental basis. ​ To enable it, source the file /​apps/​chpc/​compmech/​CFD/​OpenFOAM/​OFxt31 .+This section describes how to run OpenFOAM on the clusters at CHPC. Versions 2.2.2, 2.3.0, 2.4.0, 3.0.1, 4.0, 5.0, 6.0, 7.0, v1606+, v1612+, v1706, v1712, v1806, v1812, v1906 and foam-extend-3.1 are installed in ''/​apps/​chpc/​compmech/​CFD/​OpenFOAM''​. ​ Source the required environment from one of the files OF222, OF240, OF301, OF40, OF50, OF60, OF1606+, OF1612+, OF1706, OF1712, OF1806 or OF1906 respectively,​ as illustrated in the example job scripts below. ​ Please be aware that v1812 and v1906 use MPICH rather than OpenMPI, and the mpirun command ** has to ** select the use of the Infiniband network interface. ​ Also, you may need to source the file from your .bashrc file, to ensure that the compute nodes have the right environment. ​ This ** should ** not be necessary, but it is sometimes a useful workaround if you experience MPI troubles. ​ It is assumed that you are familiar with running OpenFOAM solvers in parallel, and have already set up the case directory. The Gmsh and cfMesh meshing utilities are also installed and are added to the executable path when any of the OFxxx files are sourced. OpenFOAM-extend-3.1 has been installed on an experimental basis. ​ To enable it, source the file /​apps/​chpc/​compmech/​CFD/​OpenFOAM/​OFxt31 .
  
 === Using MPICH instead of OpenMPI === === Using MPICH instead of OpenMPI ===
/var/www/wiki/data/attic/howto/openfoam.1562672486.txt.gz · Last modified: 2019/07/09 13:41 by ccrosby